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Pažintis su skaičiuokle

Darbinė aplinka.

· Principinės programos valdymo galimybės tokios pat kaip ir Worde. Komandos surašytos struktūrizuotuose meniu, įrankinės su komandų mygtukais analogiškai iškviečiamos į ekraną, kai to reikia: View>Toolbars...

· Darbolapis sudarytas iš karkasinės lentelės iš 256 stulpelių ir 65536 eilučių. Stulpeliai žymimi abėcėlės eilės tvarka raidėmis (A, B,...AA, AB,...), eilutės skaičiais. Paprastai rodoma tik dalis lentelės, kai reikia slinkties juostų pagalba galima patekti į norimą sritį. Duomenys rašomi į langelius, kuriuos apibrėžia jų koordinatės.

· Darbolapio ekraną galima padalyti į keturias dalis – vertikaliai ir horizontaliai: Windows>Split. Kiekviena sritis turi savo slinkties juostas

· Darbolapių gali būti keli. Jų pavadinimai (Sheet) matyti ekrano apačioje. Duomenys kiekvienam darbolapyje gali egzistuoti savarankiškai arba būti tarpusavyje susieti.

· Veiksmas atliekamas aktyviame langelyje – pastarasis apibrėžtas storesne linija. Spragsėdami su pele galime pasirinkti norimą langelį.

· Duomenis galime rašyti: a) langelyje – du kartus spragtelėjus pele langelį pelės pliusas pavirs į teksto žymeklį arba b) formulės eilutėje, kuri yra iš kart po įrankinių. Formulės eilutės pradžioje matyti aktyvaus langelio koordinatės. Papildomi simboliai (jie matyti kai txt. žymeklis yra formulės eilutėje): X – atšaukia parašytus duomenis (Cansel atitikmuo); ( – fiksuoja parašytus duomenis (Enter atitikmuo).

Dokumentų išsaugojimas

· Skaičiuoklės dokumentai išsaugomi su plėtiniu xml. Dokumento varde nevartojami simboliai: / \ : * ? „ < > |. Vardo ilgis iki 218 simbolių. Galutinis rinkmenos kelias (aprašas, kur saugoma rinkmena) turi būti ne ilgesnis nei 255 simboliai.

· Skaičiuoklės kelis dokumentus galima išsaugoti kaip „knygą“. Šis veiksmas atliekamas taip: atidaromos kelios rinkmenos, kurios sudarys „knygą“; įvykdome komandą: File>Save Workspace...

Darbas su langeliu

Langelio pasirinkimas: langelis pasirenkamas spragsint per jį pele. Sukūrus naują dokumentą, aktyvus būna lentelės pirmasis langelis. Klaviatūros rodyklės ir kitos txt. žymeklio valdymo komandos naudojamos worde tinka ir čia judėti nuo vieno langelio prie kito. 

Judėjimui naudojami Home, End, PafeUp, PageDown ir rodyklių klavišai.

Langelių žymėjimas:

· Keli langeliai iš eilės pažymimi tempiant pele, kai yra nuspaustas pelės kairysis mygtukas. Laikant nuspaudus CTRL klavišą ir tuo pat metu spragsint pele, žymimos kelios langelių sritys. 

· Stulpelis ar eilutė žymimi spragsint pele stulpelio ar eilutės pavadinimus (klaviatūra: CTRL+tarpo klavišas – žymimas stulpelis; SHIFT+ tarpo klavišas – eilutė).

· Visa lentelė (darbolapis) žymimas spragtelėjus tuščią lentelės sritį lentelės viršuje, kairėje (klaviatūra: CTRL+SHIFT+TARPO KLAVIŠAS).

· Bloko žymėjimas klaviatūra: F8; rodyklių klavišai. Kitas būdas: SHIFT+rodyklių klavišai

Judėjimas aktyvioje srityje (aktyvi sritis tai darbolapio stačiakampis su langeliais, kuriuose yra duomenys):
· Home klavišas – į aktyvios eilutės pradžią.

· End klavišas – įjungiamas END režimas. Spausdami rodykles galėsite judėti iš vienos srities į kitą.

· Ctrl+Home – peršoksite į pirmąjį lentelės langelį.

· Ctrl+End – pateksite į aktyvios srities paskutinio stulpelio paskutinį langelį.

· Pažymėto bloko ribas galite pakoreguoti, laikydami nuspaudę Shift klavišą.

TEKSTO RAŠYMAS
Skaičiuoklėje duomenys rašomi langelyje. Duomenys yra dviejų tipų: konstantos ir formulės.

Konstantos skirstomos:

· skaitinės reikšmės (numeric value);

· tekstas (text value);

· datos ir laiko reikšmės (data and time value)

· loginės reikšmės (logical value)

· klaidų reikšmės (error value)

Skaičių ir teksto rašymas

Skaičius ir tekstą galima rašyti pačiame langelyje – 2 kartus spragtelėję pele arba nuspaudę F2 (redagavimo režimas) arba Formulės eilutėje. Duomenis užfiksuojame spausdami Enter klavišą arba ( mygtuką. Klaidos taisomos su Backspase klavišu.

Į langelį galima įrašyti 32767 simbolių konstantą arba 1024 simbolių formulę.

Teksto atvaizdavimas langelyje

· Jei gretimi langeliai tušti, renkamas tekstas automatiškai išplečiamas į kitus langelius. Galime gauti panašų vaizdą, kaip Worde.

· Jei gretimi langeliai užimti, paspaudus Enter, netelpantis į langelį tekstas paslepiamas (bet nenaikinamas). Norint jį pamatyti reikia arba praplėsti langelio plotį arba leisti tekstui skleistis keliomis eilutėmis: kai langelis pažymėtas (ne redagavimo režimas), įvykdykite komandą – Format>Cell. Puslapyje Alignment pasirinktis Text Wrap.

· Jei skaičius netelpa langelyje, po Enter paspaudimo skaičiams pritaikomas General formato taisyklės, t. y. skaičius pateikiamas eksponentiniu formatu (pvz., skaičius 1254698722555 bus parašytas taip:  1,25469E+12).

· Jei skaičius, kuriam pritaikytas pinigų ar datos formatas, netelpa langelyje, tai po Enter paspaudimo jis pakeičiamas ### simbolių eilute. Praplatinus langelį, vėl išvysite tikruosius skaičius.

DARBOLAPIO TVARKYMAS
Galima keisti darbolapio pavadinimą, nuspalvinti kortelę, įterpti naują, ištrinti esamą, pakeisti jo vietą atžvilgiu kitų darbolapių. Visą tai galite atlikti nuspaudę pelės dešinį klavišą ant darbolapio kortelės.

Darbolapio aplinką visada galite pakeisti atvėrę Pasirinkčių langą: Tools>Options>View... 

Stulpelių plotis ir aukštis

Standartinis kelias: pažymimas stulpelis ir vykdoma komanda: Format>Column>Width... Maksimalus stulpelio plotis yra 255 simboliai (10 pt dydžio simboliams). Galima nurodyti ir cm. Praktiškai naudinga nustatyti AutoFit Selection, tuomet nereikės patiems nieko derinti (nuo duomenų kiekio, stulpelio plotis pasikeis automatiškai).

Su pele stulpelių plotį keičiame tempdami stulpelio pavadinimo skiriamąją liniją. Automatiškai stulpelio plotis padidėja tiek kiek reikia du kartus pele spragtelėjus stulpelio pavadinimo dešiniajame šone (AutoFit komanda).

Eilutės aukštis keičiamas: Format>Row>Height... Arba naudojame AutoFit komandą.

Eilutės aukštis keičiamas pele tempiant eilutės pavadinimo skiriamąją liniją.

Langelių redagavimas

Langeliai standartiškai nėra įrėminti. Norėdami juos įrėminti ar nuspalvinti kraštines ar foną turime įvykdyti atitinkamą komandą: pažymimas langelis, Format>Cells>Border...

Format>Cells dialogo lange galime pakeisti ir duomenų tipą (Number), ir teksto kryptį (Alignment), ir šriftą (Font).

Langelių trynimas

Atliekant trynimą, galima gauti kelius rezultatus;

· Galima ištrinti (panaikinti tik formatavimo požymius): Edit>Clear>Formats

· Galima ištrinti duomenis: Edit>Clear>All arba klavišas Delete.

· Galima ištrinti patį langelį: Edit>Delete

Stulpelių ar eilučių įterpimas ar trynimas

Jei norite įterpti vieną stulpelį (eilutę) įvykdykite komandą; pažymėkite stulpelį (eilutę), šalia kurio norėsite įterpti kitą; Insert>Columns (Rows)...

Jei norite įterpti kelis stulpelius (eilutes), pažymėkite tiek stulpelių (eilučių) kiek norėsite įterpti naujų ir pakartokite komandą: Insert>Columns (Rows)...

Jei norite ištrinti stulpelį (eilutę), įvykdykite komandą: Edit>Delete>Entire Column (Row). Rezultatas – stulpelis (eilutė) bus ištrintas, o greta esantys stulpeliai pervardinti (pavadinimų seka nesugrius).

DUOMENŲ PILDYMAS IR REDAGAVIMAS
Duomenų pildymas

Jei duomenys diskretiški, jie pildomi rankiniu būdu. Paspaudus Enter klavišą, užbaigiame rašymą.

Jei galime nustatyti duomenų seką, tai langelių užpildymą galima pagreitinti:

· Edit>Fill. Pirmiausia įrašoma norima vertė į pasirinktą langelį. Po to pažymima sritis kuria norėsime užpildyti. Tuomet įvykdoma aukščiau paminėta komanda, nurodant pildymo kryptį.

· Jei duomenų sekoje išlaikyta sąlyga, kad gretimi duomenys skiriasi žinoma konstanta, tai užpildome pirmąjį ir antrąjį langelius, pažymime juos ir įvykdome komandą: Edit>Fill>Series... Atvertame dialogo lange reikės nurodyti sekos paskutinę vertę. 

· Series dialogo lange galima pasirinkti ir kitas siūlomas pildymo sekas, tame tarpe ir dienų, savaičių, mėnesių ar metų sekas. Visuomet darbolapyje turime nurodyti pradinę duomenų sekos vertę.

· Aukščiau minėtus duomenų pildymo veiksmus galite įvykdyti pele. Pažymėtas langelis (sritis) yra įrėmintas, o rėmelio apačioje dešinėje yra užpildo rankenėlė. Su pele užpildo rankenėlę tempdami norima kryptimi užpildome pasirinktas sekas. Jei tempiame vieno pažymėto langelio užpildo rankenėlę – kiti langeliai užpildomi pirmojo langelio verte. Jei pažymime du langelius, kuriuose yra nurodyta galima seka – tempdami dviejų langelių stačiakampio užpildo rankenėlę – kitus langelius užpildysime seka (arba kopija – rezultatą galima keisti pasirenkant intelektualios žymės siūlymus)

Kuriamos sekos bus didėjančios, jei  judesys bus į dešinę ar žemyn, mažėjančios – judant į kairę ar aukštyn. Jei užpildo rankenėlę tempsite į duomenų bloko vidų – duomenis ištrinsite.

Duomenų kopijavimas

Pažymėti duomenys kopijuojami Edit>Copy. Po šio veiksmo langelis, kurio duomenys buvo kopijuoti pažymimas punktyrine linija. Jei tuojau pat neatliksite įklijavimo veiksmo, nukopijuoti duomenys bus „pamiršti“. Kad taip neatsitiktų, būtina išsikviesti Mainų sritį View>Toolbar>Task Panel,  Clipboard.

Duomenis galite kopijuoti ir vilkdami užpildo rankenėlę – tereikia intelektualios žymės lentelėje nurodyti reikiamą komandą.

Kopijuoti galima ne tik pačius duomenis, bet ir duomenų formatą.

Naujų sekų kūrimas

Jei dažnai naudojate tuos pačius sąrašus, galite juos aprašyti kaip seką. Ši procedūra gali būti taip atliekama:

· Kai darbolapyje turite surinktą reikalingą sąrašą: Tools>Options, Custom List. Atvertame Options dialogo lange laukelyje Import list from cels nurodome sąrašo koordinates (arba pele spragtelkite nuspalvinta laukelio sritį, išeisite į darbolapį; pažymėkite sąrašą; grįžkite į Options dialogo langą. Spragtelkite mygtuką Import ir Add.

· Kai dar nesate surinkę tokio sąrašo: Tools>Options, Custom List dialogo lange laukelyje List entries: surinkite reikiamą sąrašą, žodžius skirdami kableliais ir fiksuokite Add mygtuką.

Kai reikės darbolapyje parašyti jau esamą sąrašą, surinkite sąrašo bent vieną žodį, pažymėkite langelį ir tempkite užpildo rankenėlę. Programa atkurs visą sąrašą.

Programa pati gali įsidėmėti seką iš trijų gretimų langelių. Jeigu vienoje vietoje surinkote seką, kurią vėl ketinate rinkti kitoje vietoje, tai surinkus pirmuosius simbolius programa pasiūlys variantą. Jei jis tinkamas, spauskite Enter. 
SĄRAŠAS
Duomenų sąrašas Skaičiuoklėje atitinka duomenų bazės analogą – langelių sritys, užpildytos struktūruotais duomenimis. Paprastai pirmoji eilutė nusako stulpelio pavadinimus – laukus, o kitose eilutėse yra duomenų įrašai. 

Rekomendacijos, kurių reikia laikytis kuriant sąrašą (duomenų bazę): 

· viename darbolapyje yra tik vienas sąrašas; 

· sąrašuose nepalikite tuščių stulpelių ir eilučių; 

· viename stulpelyje įveskite tik vienodo tipo duomenis; skaičių nemaišykite su tekstu ir loginėmis vertėmis; 

· stulpeliams naudokite antraštes; 

· įjunkite pasirinktį: Tools>Options, Edit: Extend list formats and formulas, tuomet bus taikomas automatinis formatavimas naujiems duomenims.

· jei planuojate sąrašą filtruoti, nerašykite jokios kitos informacijos sąrašo užimamose eilutėse.

Išlaikius anksčiau minėtas rekomendacijas, sąrašas Skaičiuoklėje bus atpažįstamas automatiškai. 

Sąrašo sudarymas
Sąrašo duomenys pildomi įvairiai:

I. Duomenys imami iš kitos programos: 

– kaip ištisinis tekstas skaidomas stulpeliais: 1) duomenis įklijuoti į A1; 2) iškviesti komandą Data>Text to Columns... (Text to Columns – suskaido tekstą skiltimis pagal fiksuotą simbolių skaičių arba remiantis skyrikliais – tarpu, kableliu ar pan., ir patalpina į atskirus stulpelius.  Skaidomas tekstas turi būti viename langelyje).

a) Užpildomi stulpeliai (vienoje eilutėje).

b) Suskaidytą tekstą stulpeliuose perkelti į 1 stulpelį: nueiti į paskutinį užpildytą stulpelį – END, rodyklė į dešinę. Pažymėti – Shift+Home. Nukopijuoti. Pažymėti A2. Edit>Specialus įklijavimas – Transpose (eilutės keitimas stulpeliu). Tekstas automatiškai bus perkeltas į nurodyto stulpelio eilutes.
II. Serijinių (sekų) duomenų pildymas: Edit>Fill>Series...

III. Rankinis rinkimas duomenų: automatiškai užbaigiamas rinkti tekstas, jei jis anksčiau jau buvo rinktas. Tai apsprendžia pasirinktis: Tools>Options, Edit; Enable AutoComplete for cell value.

IV. Reikšmės parinkimas iš sąrašo, naudojant komandą Pick from List (pasirenkama iš kontekstinio meniu). Prieš tai tokį sąrašą reikia sukurti Tools>Options>Custom List lange.

V. Pildomi duomenys tenkina tam tikrą kriterijų. Kriterijams apibrėžti naudojama Data>Va​li​dation komanda. Pažymimas stulpelis, kuriame bus apriboti duomenys, ir vykdoma Data>Vali​dation. Nurodyti galima:

· Any value – bet kokia reikšmė (be apribojimų)

· Whole number – bet kuris nurodyto intervalo skaičius

· Decimal – bet kuris trupmeninis nurodyto intervalo skaičius

· List – tik išskleidžiamojo sąrašo reikšmė. Leidžiamų reikšmių sąrašą reikia turėti jau surinkus, nes reikės nurodyti jo koordinates.

· Date – bet kuri nurodyto intervalo data

· Time – bet kuri nurodyto intervalo laiko reikšmė

· Text lenght – intervalu nurodyto ilgio teksto eilutė

· Custom – reikšmė, tenkinanti formule užrašytą sąlygą. Leidžiami rinkti duomenys, kurie tenkins formulę. Pvz. =(B1>A1). Puslapyje Input Mesage (įvesties pranešimas) nurodome pranešimo apibūdinimą ir apribojimus. Error Alert puslapyje galime sulietuvinti pranešimą, kai padaroma klaida: Stop; Warning (perspėjimas yra mygtukas Retry); Information – tik perspėja, bet mygtuko Retry nėra.

VI. Duomenys pildomi naudojant formą. Data>Form. 
Jeigu apibrėžėte sąrašo laukus, tai duomenis galima surašyti naudojantis forma. Automatiškai sukuriamas sąrašo eilutės maketas, kuriame galima peržiūrėti, pridėti, pakeisti, pašalinti arba surasti reikiamus įrašus. Formos vardui priskiriamas darbolapio pavadinimas. Formoje matote sąrašo vieną įrašą. Formoje gali būti iki 32 laukų. Redaguojamuose laukuose galima rašyti duomenis, o formulių laukuose (skaičiuojamieji arba saugieji laukai) pateikiami formulių rezultatai.

Naujus duomenis galėsite įvesti naudodami programos siūlomą formą: Data>Form:
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Pvz. Duomenų forma
Užduotis...

Duomenų sąraše rikiavimas
Duomenis rikiuojami, kad būrų galima greičiau juos apdoroti pagal pasirinktą kriterijų. Parenkamas tvarkymo kriterijus – įrašo laukas – vadinamas rikiavimo raktu.  Tai gali būti pavardės stulpelis, inventoriaus numeris ir t.t.

Surikiuoto sąrašo duomenys randami ir analizuojami žymiai greičiau ir patogiau. Be to, surikiuotų duomenų sąraše galima apdoroti įrašus, turinčius bendrą požymį. Jei skaičiai turi teksto formatą (prieš juos parašyta apostrofa), jie rikiuojami kaip tekstas. Apsidraudimui sąrašo pradžioje tikslinga turėti stulpelį, kuriame nurodoma eilės tvarka. Vėliau, jei lentelės struktūra būtų sugriauta (sąrašas gali būti sugriautas, jei rikiuosite ne visą sąrašą ir pažymėsite ne visus stulpelius, bus perspėjimas), galėsite atlikti rikiavimą pagal šį lauką ir grįšite į pradinę būseną.

I. Greitojo rikiavimo mygtukai. [image: image2.bmp] [image: image3.bmp].  Naudojami rikiavimui pagal vieną raktą.

Rikiavimo panaikinimas. Edit>Undo Sort.

II. Data>Sort – duomenų rikiavimas. Surikiuoja sąrašo eilutes ar stulpelius pasirinktų raktų didėjimo ar mažėjimo tvarka.

Rikiavimas pagal kelis kriterijus, nurodoma rikiavimo kriterijų eiliškumas. Rikiavimo tvarka – Ascendind – didėjimo linkme skaičiai. 

Teksto atveju – taip, kaip išdėstyti žemiau:

(tarpas)‘-!”#$%&()*,./:;?@[\]^_`{|}~<=>(euras)0123456789AĄBCČDEĖĘFGHIJKLM NOPQRSŠTUŪŲVWXZŽ
Ignoruojamos didžiosios ir mažosios raidės (tarsi būtų visos didžiosios). Tačiau  galima nustatyti kitaip (Case sensitive), tuomet mažosios eis pirmiau, nei didžiosios.
Loginės vertės: False (Ne), po to True (Taip).

Tušti langeliai perkeliami į sąrašo galą, nepriklausomai nuo rikiavimo tvarkos – didėjimo ar mažėjimo kryptimi.
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Pvz. „Rūšiavimo“ dialogo langas

Rikiavimas formoje. Data> Form.

Veiksmai formoje: nuspaudę New, galėsite įrašyti naują įrašą; Delete – ištrinti įrašą; Restore – atkurti pradinius įrašus; Find Prev – peržiūrėti ankstesnį įrašą; Find Next – peržiūrėti tolesnį įrašą; 

Criteria – galėsite nustatyti paieškos kriterijų:

· nurodykite konkrečią konstantą;

· užduokite palyginimo sąlygas. Standartiniai santykio ženklai: = (lygu), > (daugiau), < (mažiau), >= (daugiau arba lygu), <= (mažiau arba lygu), <> (nelygu).
Duomenų filtravimas
Paprastas duomenų filtravimas. Data>Filter – duomenų paieška sąraše pagal nurodytus kriterijus. Rodomi tik atrinkti duomenys

Standartiškai rikiuojamos eilutės. Stulpeliu rikiuosite, jei Sort dialogo lange atversite Options langą ir nurodysite pasirinktį: Sort left to right.

Data>Filter, Autofilter. Po šių veiksmų prie stulpelių pavadinimų atsiras rodyklės. Paspaudę vieną iš jų, galėsite nurodyti kokius duomenis peržiūrėti: All – visus; TOP 10 – 10 didžiausių; Bottom – mažiausias vertes; pasirinkite norimus. Jei pasirinksite Custom – galėsite nurodyti atrankos individualius kriterijus. 

Duomenų atranką vykdykite pagal vieną pasirinktą stulpelį. To stulpelio Autofilter rodyklė bus nuspalvinta mėlynai. Kai norėsite atlikti duomenų atranką pagal kitą stulpelį, reikės atšaukti prieš tai buvusią atranką – nuspaudę Autofilter mėlyną rodyklę, pasirinkite All (arba Data>Filter, Show All), tuomet vėl matysite nepakeistą visą sąrašą.

Autofilter rodykles panaikinsite atšaukę Autofilter komandą: Data>Filter>Autofilter.

Autofilter komanda galima filtruoti kelis kartus nurodant kitus kriterijus
Sudėtingas filtravimas.  Data>Filter>Advanced Filter –  Duomenų atranka pagal nurodytą sudėtingą kriterijų. Vienu metu galima filtruoti tik vieną sąrašą.

Išrinkti duomenys gali būti talpinami kitame darbolapyje. Iškviečiant šią komandą, reikia tinkamai paruošti kriterijus. Kriterijai rašomi iš karto po sąrašu, nes turi likti stulpelių pavadinimai arba ne sąrašo srityje, tiksliai užrašant laukų pavadinimus. 

Jei vykdoma atranka pagal tekstą, jei reikia, galima naudoti pakaitos simbolius išraiškose: ? – žymi bet kokį vieną simbolį, * –žymi bet kokį simbolių kiekį, tildės ženklas ~ rašomas prieš ?, * ar ~, jei tie simboliai yra ieškomam tekste. Tiksli teksto išraiška rašoma kabutėse, naudojant formulės sintaksę, pvz., =''=text''.

Pvz.1.  Sąraše palikti įrašus, kurie tenkintų sąlygas: stulpelyje „Dalyviai“ įrašas tiksliai sutaptų su „Jurgelytė“, o stulpelyje „Premija, Lt“ – skaičiai būtų didesni už 300,00. Sąlygas užrašome taip:

	Dalyviai
	Premija, Lt

	=“=Jurgelytė“
	>300,00


Pvz.2. Sąraše palikti įrašus, kurie tenkintų sąlygas: stulpelyje „Dalyviai“ įrašai prasidėtų „Ju“, o stulpelyje „Premija, Lt“ – skaičiai būtų didesni už 300,00. Sąlygas užrašome taip:

	Dalyviai
	Premija, Lt

	Ju*
	>300,00


– jei nurodomi keli kriterijai tam pačiam stulpeliui, jie rašomi atitinkamo stulpelio keliose eilutėse.

– jei kriterijaus išraiška yra formulė, ji neturi būti rašoma stulpelyje, kuris turi sąrašo pavadinimą.
Atverkite Advanced Filter dialogo langą, nurodykite duomenų sąrašo koordinates (List Range) ir atrankos kriterijaus koordinates (Criteria range). Gausite duomenų atranką. 
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  Pvz. Sudėtingo filtravimo dialogo langas

Unique records only – atrinks nesutampančius įrašus.

Advanced Filter galima filtruoti tik vieną kartą (ne taip kaip Autofilter atveju).

Kriterijų blokas. Pirmoje kriterijų bloko eilutėje rašomi kriterijų vardai. Eilutėse po kriterijų vardais rašomos reikiamos sąlygos. Kriterijų blokas turi būti dviejų eilučių aukščio ir bent vieno stulpelio pločio. Jame paieškai nurodomi dviejų tipų kriterijai. Jei yra palyginimo kriterijus, tai jų vardai turi sutapti su sąrašo laukų vardais. Jei yra skaičiuojamasis kriterijus, jo vardas neturi sutapti su sąrašo laukų vardu.

	
	
	

	Metai
	Taškai
	

	1990
	>60
	

	kriterijų bloko struktūra


Duomenų grupių apskaita sąraše
 (Data>Subtotals – grupių sumos)
Duomenys sudėtingos struktūros sąraše gali būti skaidomi grupėmis, pagal bendrą požymį ir tokioms grupėms taikomi skaičiavimai – dalinės sumos (vidurkis, maksimalios, minimalios vertės ir t.t.). Skaičiuojant grupių sumas kartu sukuriama sąrašo grupių schema (outline) – sąrašo kairėje atsiras mygtukai, kuriais galima paslėpti išsamius duomenis ir analizuoti tik apibendrintus grupių duomenis.

Veiksmų eiliškumas:

· Sąrašo stulpeliams turi būti suteikti vardai

· Sąrašą surikiuoti taip, kad tą patį grupės požymį turinčios eilutės atsidurtų greta (Data>Sort)

· Pažymėti vieną sąrašo langelį. Įvykdome komandą: Data>Subtotals. Atvertame Subtotal dialogo lange parenkame parametrus:

· At each change in (po kiekvieno stulpelio reikšmių pokyčio) – nurodome tą stulpelį, kuriame yra grupės turinčios tą patį požymį (sąrašas surikiuotas pagal šį stulpelį);

· Use function: laukelyje nurodome apibendrinančią funkciją (sumavimas, vidurkis ir t. t.);

· Add subtotal to: (įterpti grupės sumą stulpelyje) – nurodome stulpelius, kuriems bus taikoma pasirinkta funkcija.

Papildoma pasirinktis – Page break betveen groups – kiekviena duomenų grupė pateikiama naujame puslapyje.
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  Pvz. Dialogo langas „Grupių sumos“

Papildoma pasirinktis – Summary below data – jei jos nepažymėsite, apibendrinti viso sąrašo duomenys bus pateikti viršuje sąrašo. Žr. pvz..

Galima naudoti kelias apibendrinančias funkcijas. Pasirinkę pirmąją funkciją, komandą įvykdykite iki galo. Tuomet vėl grįžkite į Subtotal dialogo langą, pasirinkite kitą funkciją, nuimkite varnelę nuo pasirinkties – Replace current subtotals; OK.

Taip pat galite gauti filtruoto sąrašo grupių sumas – prieš tai sąrašą reikia filtruoti, po to surikiuoti, po to įvykdyti Data>Subtotals komandą. Bus pateikti tik ekrane matomų eilučių apibendrinantys duomenys.
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Pvz. Dalinių sumų pavyzdys

Grupių apibendrinančius duomenis panaikinsite Data>Subtotal dialogo lange pasirinkę komandą Removal All.
Pritaikę automatinį formatavimą – Format>Autoformat – apibendrintus duomenis gausite paryškintus, bus lengviau analizuoti.

Duomenų grupės
Data>Group and Outline – grupės ir grupių schemos. Grupuojamos didelio sąrašo eilutės ir stulpeliai. Pateikiama šių grupių schema.

Duotame Dalinių sumų pavyzdyje E stulpelyje panaudota formulė, kuri naudoja duomenis iš stulpelių, esančių kairėje. Tokiai schemai galima pritaikyti duomenų grupavimą stulpeliais, t.y. virš stulpelių taip pat galima sukurti įrankius duomenims rodyti ar slėpti. 

Veiksmų eiliškumas:

· Pažymėti duomenis

· Įvykdyti komandą: Data> Group and Outline, Auto Outline.

[image: image9.png]E3 Microsoft Excel - subtotals.
He Et Vew et Fgmak ok Dats window e SR
DeEdat 8RY 4B |- @ =-4E P -0,
el w0 -BZuU =% % , B3 B2 A,
E19 > A =C19-D19
A B E F G H J K L M N 8] P Q
1 Data Pavardé Pelnas.

2 2008, rugs|Juozaitis §$1,187 .50
3 2006, rugs|Juozaitienée | 1,045.00
4 2008, rugs|Jonynas 1919.00
5 2008, rugs|Urba 1,729.00
B 2006, rugs|Pakerys 1,463.00
7 2008, rugs|Dirgéla 1938.00
8 2006, rugs|Leonavigius | 1,520.00
9 2008, spallJuozaitis §$1852.50
10 2008, spallKazlauskas | 1,520.00
11 2008, spallJonynas 2,394.00
12 2008, spallUrba 2§79.00
13 2008, spallPakerys 1,843.00
14 2008, spal|Dirgéla 2527.00
15 2008, spallLeonavigius | 2,470.00
16 2008, lapk|Juozaitis $2,907.00
Kazlauskas | 3,220.50
353400
3547 50
20 2006, lapk|Pakerys 4,161.00
21 2008, lapk|Dirgéla 447450
22 2006, lapk|Leonavicius | 4,788.00
23 2008, gruo|Juozaitis $4313.00
24 2008, gruo|Kazlauskas | 2 588.00
25 2008, gruo|Jonynas 4,370.00
26 2006, gruo{Urba 3,752.50
27 2008, gruo|Pakerys 342000
28 2008, gruo|Dirgeéla 1919.00
29 2006, gruo|Leonavicius | 4579.00

30 j

3 ~

i« » W\ Sibtatds /Max / Suma b arupes / I« | miN

Ready M



   Pvz. Sugrupuotų stulpelių pavyzdys.

Duotam pvz., virš stulpelių pavadinimo matyti „pliusas“ – duomenys, kurie panaudoti formulėje yra paslėpti, rodoma tik apibendrinta informacija.

SUKINYS – DINAMINĖ SUVESTINĖ
Sukinys – tai suvestinės tipo lentelė, kurioje yra galimybė pasirinkti atskirus sąrašo ar duomenų bazė susietus duomenis, gauti jų apibendrintus rezultatus, bei nusibraižyti diagramas. 
Sukiniui sukurti naudojamas PivotTable vedlys: reikės nurodyti informacijos šaltinį, jo vietą ir būsimo sūkinio vietą. Bus pateikta sukinio maketo schema, kurią užpildysite reikalingais laukais ir nurodysite kokius apibendrintus duomenis norite gauti. Tai ir bus sukinys.

Sukinio konstravimas.
Turime žinoti sąrašo struktūrą, apsispręsti kuriuos duomenų laukus naudosite, kaip juos išdėstysite sukinyje.

· Laukai, kurie sukinyje naudojami kaip eilutės lauko (row field), stulpelio lauko (column field  ar puslapio lauko (page field) pavadinimai vadinami sukinio ašimis. Jais remiantis ir konstruojami sukiniai.

· Duomenų laukuose (data field) duomenys yra apibendrinami.

· Iš sąrašo lauko elementų (item) sudaromi sukinio eilučių arba stulpelių pavadinimai.

· Skaitiniai duomenys apibendrinami duomenų srityje (data area)
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Pvz., Sukinio schema (Layout), kurią reikia užpildyti elementais.

Pateiksime sukinio schemos užpildymo variantą:

· Į A1:G1 sritį nunešame duomenis, kurie turėtų būti atvaizduojami viename puslapyje, pvz. Pamaina.

· Į A4 laukelį nunešame „Pavardės“ 

· Į B3 laukelį nunešame „Gaminys“

· Į  B4:G16 sritį talpinkite duomenis, su kuriais programa atliks skaičiavimus. Tai galėtų būti „Parduota vnt.“ – bus skaičiuojami parduotų prekių vienetai, arba „Gauta“ – bus suskaičiuota pinigų sumos už parduotas prekes.
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Pvz. Sukinio pavyzdys – kas per I-ą pamainą prekiavo, kuo prekiavo ir kiek gauta pinigų už konkrečią prekę.

Analizei galime pasirinkti mėnesį, konkretų gaminį ir pan. Programa automatiškai suskaičiuos sumas ar atliks kitą skaičiavimą – tai priklauso nuo pasirinktos formulės: PivotTable įrankių juostoje Field Options mygtukas.

Sukinio struktūrą galima keisti, nuvelkant laukų mygtukus iš vienos vietos į kitą. Nuvelkant lauką iš lentelės, laukas pašalinamas.

Papildomos galimybės:

· Pakeitę pradinius sąrašo duomenis sukinį atnaujinsite taip: Data>Refresh Data (arba Šauktukas PivotTable įrankių juostoje).

· Galite matyti pradinius duomenis sukinio langelyje – Data>PivotTable Options pažymėkite pasirinktį Enable drilldown. Du kartus spragtelkite sukinio langelį, pažymėkite kokius duomenis norite matyti. OK. Sukinyje atsiras papildomi langeliai su duomenimis.

· Sukinyje galima sugrupuoti kelis sukinio elementus – pažymėkite grupuojamus elementus ir įvykdykite komandą: Data>Group and Outline, Grup. Sukinyje atsiras stulpelis, simbolizuojantis grupę. (išgrupavimui naudokite Ungrup komandą).

· Du kartus spragtelėję sukinio išorinę eilutę ar stulpelį, galite paslėpti išsamius tos grupės duomenis. Gauti duomenys pateikiami naujame darbolapyje

· Sukinio duomenis galima rikiuoti, naudojant mygtukus [image: image12.bmp]
· Automatinis sukinio formatavimas – spauskite formatų mygtuką PivotTabla įrankių juostoje (arba Format>Autoformat). Atsisakymas formato – Autoformat dialogo lange paskutinė komanda NONE.

Struktūrinis žymėjimas sukinyje – pažymėkite langelį Sum of Gauta – bus pažymėti ir duomenys, kurie panaudoti gauti sumai.

Sukinio diagramos

Iš gauto sukinio programa automatiškai sukurs ir diagramą – spragtelkite diagramos piktogramą standartinėje įrankių juostoje. Žr. pateiktą diagramos pavyzdį. 

Jei sukinys nesukurtas, sukinio diagramą galite gauti iškvietus Data>PivotTable vedlį ir nurodžius jam kurti diagramą. Kaip ir sukinio atveju, tuščią diagramą užpildome vilkdami atitinkamus laukus
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Pvz. Sukinio diagrama

Diagramos ašyse yra duomenų pasirinkties mygtukai. Pakeitus duomenis, akimirksniu pasikeis ir diagrama. Tokiu būdu labai greitai galite atvaizduoti rūpimus duomenis. 

Ataskaitoms diagramos pateikiamos be pasirinkties mygtukų. Pasirinkties mygtukai bus nerodomi, jei  Diagramos darbolapyje Sukinio lentelės įrankių juostoje pasirinksite: Hide PivotChart Field Buttons.
SĄLYGINIS FORMATAVIMAS
Formatavimo procedūra tokia pat, kaip ir Worde. Pažymimi dominantys duomenys ir Format Cells... susirandame ir priskiriame reikiamus požymius. Galima naudotis ir atitinkamomis įrankių juostomis.

Sąlyginis formatavimas leidžia analizuoti turimus rezultatus ir jei jie tenkina tam tikrus požymius, suteikti jiems kitokį formatavimą.

Pažymimi duomenys ir Format>Conditions formatings... Atvertame dialogo lange nurodomos sąlygos ir formatavimas. Mygtuku ADD galima nurodyti tris skirtingas sąlygas.
LANGELIŲ KOORDINATĖS. FORMULĖS. FUNKCIJOS
Atliekant skaičiavimus formulėse rašomi ne duomenys, o koordinatės langelių, kuriuose yra tie duomenys.

Langelių koordinatės (adresai, nuorodos) yra dviejų stilių:

– A1 stiliaus koordinatės aprašomos stulpelio raide ir eilutės numeriu, pvz., B2. Pagal nutylėjimą šio stiliaus koordinatės ir naudojamos.

– R1C1 stiliaus koordinatės aprašomos taip: eilutę simbolizuoja R raidė, stulpelį  C raidė. Šio tipo koordinatės naudojamos kuriant makrokomandas. Prie šio stiliaus koordinačių pereinama įjungus atitinkamą pasirinkti Tools>Options>General, Setings laukelyje. 
Bendru atveju koordinatės gali būti trijų tipų:

Reliatyvios, kai atliekant kopijavimą jos pasikeičia. 
Pvz., A1 stiliaus atveju rašome B2, nukopijavus į dešinę per vieną langelį gausime C2.

R1C1 stiliaus atveju rašome R[2]C[2] – per dvi eilutes žemyn ir du stulpelius į dešinę (minuso ženklas rašomas, jei poslinkis yra į kairę ir aukštyn).
Absoliučios, kai kopijuojant, koordinatės nesikeičia. 
A1 stiliaus atveju rašomas dolerio simbolis prieš elementą, pvz., $B$2.
R1C1 stiliaus atveju rašome R2C2 – langelis antros eilės antrame stulpelyje. 

Mišrios, kai dolerio ženklas yra arba prie eilutės arba prie stulpelio simbolio. 

Pvz., A$1. 

Koordinačių tipą keičiame automatiškai, spausdami F4 klavišą.

Pavyzdžiai:

D3:D20 sritis tarp D3 ir D20 langelių. 10:10 visi langeliai 10 eilutėje;  5:10 visi langeliai nuo penktos iki 10 eilutės;  M:M visi langeliai stulpelyje M.

=SUM(D:D; H$9)  Sumuojamos D stulpelio visos eilutės ir H stulpelio 9 eilutė.
=SUM(D6;E:E;9:9)  Sumuojamas langelis D6, visas E stulpelis ir visa 9 eilutė.

=SUM(E7:G9;$H$4;$H$8)   Sumuojama sritis tarp E7 ir G9 ir pridedami konkretūs langeliai H4 ir H8.
Nuorodos į langelius iš skirtingų lapų, pvz., nuoroda į darbolapį „Kaina“: =SUM(Kaina!B3:B20). Po darbolapio pavadinimo dedamas šauktukas
Nuorodos į kitą rinkmeną: 

1) jei rinkmena, pvz., Biudzetas.xls atidaryta: =SUM([Biudzetas.xls]Kaina!B3:B20). Rinkmenos vardas nurodomas laužtiniuose skliaustuose.
2) jei rinkmena neatidaryta: =SUM('C:\Dokumentai\[Biudzetas.xls]Kaina'!B3:B20). Takas iki rinkmenos iš abiejų pusių apgaubtas apostrofomis.

Erdvinės koordinatės: nuorodos į langelius, esančius skirtinguose darbolapiuose.

Pvz.: =SUM(Sheet2:Sheet3!B5)  Sumuojamas dviejų darbolapių langeliai B5.

=SUM(Sheet1!A1:B17;Sheet4!F5:F10)     Sumuojami skirtinguose lapuose skirtingi langeliai.
Erdvinės nuorodos taikomos tik su tam tikromis funkcijomis: SUM, AVERAGE, COUNT, MAX, MIN, PRODUCT ir pan. Nenaudojamos masyvų (arrey) formulėse ir su sankirtos operatoriumi (tuščias tarpas).
LANGELIŲ VARDAI
Vietoje koordinačių į formules galima rašyti pavadinimus, kurie priskirti langeliams arba jų sričiai. Pvz., =SUM(Pajamos); 
Būtina įjunkti pasirinktį: Tools>Options>Calculations, Accept Labels in formulas.
Pavadinimo suteikimas duomenims: 
I) pirmoje eilutėje parašomas pavadinimas – „Pajamos“, stulpelis užpildomas duomenimis. Pažymime pavadinimą ir duomenis, Insert>Name>Define, Add. Kai reikia formulėje nurodyti koordinates, elgiamės taip: Insert>Na​me>Pas​te, nurodom reikiamą pavadinimą, OK.
II) kitas būdas:
a) pažymima sritis; b) Insert>Name>Create. Programa paprašo pasirinkti ar tai bus Top Row, Left Columns, Bottom Row, Right column. OK.
III) trečias būdas: 
pažymime duomenis (stulpelį ar jo dalį), tuomet koordinačių laukelyje (formulės juostoje, kairėje) rašome pavadinimą ir spaudžiame Enter. 
Bet kokiai stulpelio langelių sričiai naudojama Label komanda.
Taisyklės, kurių reikia laikytis, rašant pavadinimus:

· Pavadinimai turi prasidėti raide. 
· Galima rašyti iki 255 simbolių. 
· Nevartoti kombinacijų, primenančių įprastas koordinačių nuorodas. Negalimi tarpai.

SKAIČIAVIMAI
Skaičiavimų išraiška visuomet prasideda lygybės ženklu =. Formulė rašoma arba langelyje, arba formulės eilutėje. Pati formulė gali būti kuriama panaudojant konstantas, langelių koordinates, funkcijas ir operatorius.   
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Formulė analizuoja veiksmus ir pateikia analizės rezultatą. Skliaustai formulėje nusako veiksmų eiliškumą. Pirmiausia veiksmai atliekami skliaustuose. 

Veiksmų tvarka:
1- kėlimas laipsniu; 2- daugyba, dalyba; 3- sudėtis, atimtis.
Veiksmų operatoriai
Veiksmams atlikti naudojami operatoriai:

I)  aritmetiniai: +(sudėtis), - (atimtis), / (dalyba), * (daugyba), % (procentai), ( (kėlimas laipsniu). 
Rezultatas – skaičius. 
II) palyginimo: = (lygu), > (daugiau), < (mažiau), >= (daugiau lygu), <= (mažiau lygu), <> (nelygu). 
Atsakymas viena iš loginių reikšmių: TRUE – teisinga išraiška arba FALSE – neteisinga.

III) teksto: & (teksto tarpusavio ryšio), ženklas, sujungiantis teksto dalis į vieną. Pvz. =("Rytai-“&„Vakarai“). Gausime atsakymą: „Rytai-Vakarai“.
IV) nuorodų: srities operatorius : (dvitaškis), reiškia nuorodą į langelių sritį, pvz., A25:A35.
Jungties operatorius kabliataškis ; (arba kablelis ,) sujungia atskiras sritis į vieną, pvz., =SUM(B5:B15;D5:D15).
Sankirtos operatorius tuščias tarpas. Jo rezultatas, nuoroda į langelių sritį, kuri bendra visoms sritims. Pvz., =SUM(D6:F10 F6:H9). Atsakymas suma iš  F6:F9.

Šių operatorių eiliškumas: 

1) Pirmiausia vykdomi nuorodos operatoriai: dvitaškis, po to tarpas, kabliataškis (kablelis), neigimo (-1);
2)  antroje vietoje aritmetiniai operatoriai: minusas, procentai, kėlimas laipsniu, daugyba ir dalyba, sudėtis ir atimtis.

3) trečioje vietoje teksto ir palyginimo operatoriai.
Veiksmų eiliškumui keisti naudojami skliaustai.

Formulių rašymas
Parašę lygybę =, formulę kuriate patys arba pasitelkiate Excelyje esančias funkcijas. Aritmetinius operatorius rašote su klaviatūra, minuso ženklas rašomas skliausteliuose, veiksmų eiliškumą apibrėžiate skliaustais. Pabaigus rašyti formulę, spaudžiate Enter. Tame langelyje, kur rašėte formulę, matysite atsakymą, o pačią formulę matysite formulės eilutėje. Jei reikės, ten ją ir redaguokite.
Jei norėsite atlikti veiksmus su duomenimis, esančiais ne vienam langelyje, o tam tikroje srityje, naudokite funkcijas. Sritį galima nurodyti tik kaip funkcijos argumentą.

FUNKCIJOS
Funkcija – tai paruošta formulė. Kokius reikės atlikti veiksmus jau yra užprogramuota ir „paslėpta“ po funkcijos pavadinimu. Mums tereikės teisingai nurodyti skliausteliuose po funkcijos pavadinimu argumentus, kurie apspręs galutinį atsakymą. Funkcijos gali turėti ne vieną argumentą. Argumentai, tai langelių koordinatės. Langeliuose gali būti skaičiai (number), duomenų masyvai (Array), arba kitos vertės (value): tekstas, loginės vertės (True, False), ar kita funkcija. Argumentai atskiriami kabliataškiu (kableliu). Tarpeliai nerašomi, išskyrus vienintelį atvejį, kai naudojame sankirtos operatorių. Kai kurios funkcijos gali turėti iki 30 argumentų. Neprivalomi argumentai nurodomi laužtiniuose skliausteliuose.
Funkcijų dialogo langą lengvai iškviesite Shift+F3, arba fx mygtuku įrankių juostoje. Jei formulės juostelėje parašėte lygybę, dažniausiai naudojamas funkcijas matysite nuspaudę trikampį formulės juostos kairėje. 
Išsirinkus funkciją, bus atvertas Insert Function dialogo langas. Select function laukelyje pasirenkame reikiamą funkciją (lentelės apačioje, kai funkcijos pavadinimas pažymėtas, matysite trumpą funkcijos aprašą), OK. Funkcijos argumentų dialogo lange argumentus nurodome taip: spragtelkime veiksmo mygtuką – laukelio dešinėje, pereisim į darbolapį su duomenimis; pele pažymime duomenis, vėl spragtelkime veiksmo mygtuką lentelėje; grįžtame į Funkcijos argumentų dialogo langą. Jei reikia, nurodome kitą argumentą ir t.t. Funkciją užbaigsime, nuspaudę OK mygtuką. Formulės laukelyje matysite funkciją su argumentais, o aktyviame langelyje atsakymą.  
Argumentai funkcijoje skiriami kabliataškiu, tekstas rašomas kabutėse. Jei reikia, aritmetiniai veiksmai rašomi klaviatūra. Skaičiavimai atnaujinami automatiškai: Tools>Options>Calculation, Automatic arba F9.
Parašytą formulę galite kopijuoti į kitą langelį. Funkcijoje argumentai pasikeis, jei panaudotos reliatyvios koordinatės.
Loginių verčių skaitinė išraiška:

TRUE (teisingas, teigiamas vertinimas) prilyginamas 1;
FALSE (neteisingas, neigiamas vertinimas) prilyginamas 0.
Funkcijos:
Financial – finansinės;
Date ir Time – Datos ir Laiko; 
Math ir Trig – matematinės ir trigonometrinės;
LookUP ir Reference – paieškos ir nuorodų;

Statistical – statistinės;

DataBase – duomenų bazių;

Text – teksto;

Logical – loginės;

Information – informacinės.
Populiarios funkcijos

1. SUM(number1;number2;...).  Sumavimo funkcija.
Sumuojami argumentai, jų gali būti iki 30. Gali būti atliekami veiksmai ir su tekstu, žr. pav. 
Pvz.:  =sum("Europa"="Europa")=1, bet =sum("Europa"="Euras")=0. Sumuojamos ir loginės vertės: True=1 ir False=0
2. sumif(range;criteria,[sum_range]). Sąlyginis sumavimas.
Sumuojami tie duomenys, kurie tenkina kriterijų. 

Pvz.:  =sum(C3:C15; ">5") - sumuojamos tos reikšmės iš intervalo C3:C15, kurios didesnės už 5.

3. Average(number1;number2;...). Vidurkis.
skaičiuojami nurodytų argumentų aritmetinis vidurkis. Argumentu gali būti skaičiai ar vardai, masyvai ar nuorodos iš skaičių.
4. sqrt(number). Kvadratine šaknis.

Pvz.: =sqrt(64)=8.
5. count(value1;value2;...). Suskaičiuoja langelius su skaitinėmis vertėmis arba langelius su skaitiniu sąrašu.
6. counta(value1;value2;...). Suskaičiuoja netuščius langelius (langeliuose gali būti ne tik skaičiai).

7. countblank(range). Suskaičiuoja tuščius langelius nurodytoje srityje.

8. countif(range;criteria). Kriterijus yra skaičius, išraiška, tekstas. Suskaičiuoja tuos langelius, kuriuose esanti informacija tenkina kriterijų.

Pvz.: langeliuose B3:B6 yra skaičiai 32,54,75,86. Suskaičiuoti, kiek yra įrašų, didesnių už 56?
=countif(B3:B6;">56")=2.
9. Max(number1;number2;...). Atsakymas maksimali reikšmė iš skaičių sąrašo. Ignoruojamos loginės vertės, tušti langeliai ir tekstas.

10. Maxa(value1;value2;...). Argumentas yra skaičiai, loginės vertės, tekstas. Atsakymas maksimali reikšmė iš verčių sąrašo. Jei langeliai tušti Maxa()=0.

Pvz.: =maxa(10;100;23)=100.             =maxa(0;True)=1.
11. min(number1;number2;...). Atsakymas minimali reikšmė iš skaičių sąrašo. Ignoruojamos loginės vertės, tušti langeliai ir tekstas.

12. mina(value1;value2;...). Argumentas yra skaičiai, loginės vertės, tekstas. Atsakymas minimali reikšmė iš verčių  sąrašo. Jei langeliai tušti Mina()=0.
13. MODE(number1;number2;...). Dažniausiai pasikartojanti reikšmė sąraše.. Ignoruojamas tekstas, tušti langeliai, loginės vertės.

Pvz.: =mode(2;3;2;1,5;10)=2.
Tekstinės funkcijos
1. CHAR(number). Funkcija grąžina simbolį, kurio kodas yra skaičius (argumentas), nuo 1 iki 255.

Pvz.: =CHAR(0169)=©. 

2. CODE(text). Gražina įvesto simbolio kodą. Tekstas rašomas kabutėse!
Pvz.: =CODE("ū")=251

3. CONCATENATE(text1;text2;...). Sujungia tekstus į vieną bloką. Tarp sujungiamų dalių rašome skirtuką arba tarpą po tekstu kabutėse.
4. LEN(text). Suskaičiuoja simbolių skaičių eilutėje, įskaitant ir tarpus ir skyrybos ženklus.

5. LOWER(text). Konvertuoja didžiąsias raides į mažąsias.

6. UPPER(text). Konvertuoja mažąsias raides į didžiąsias.

7. PROPER(text). Keičia pirmąsias žodžio raides į didžiąsias.

8. MID(text;start_number;num_chars). Ištraukia tekstą iš eilutės, pradedant start_number. Iš viso num_chars raidžių.
Pvz.: =MID("Vilniaus universitetas";10;13)=universitetas.

9. REPLACE(old_text[senas_tekstas];start_num;num_chars[kiek_pozicijų];"new_text[kokiu_tekstu]). Vieno teksto pakeitimas kitu. 
Pvz., langelyje G23 yra tekstas "Vilniaus universitetas". Keisime į "Klaipėdos universitetas" tokiu būdu: =REPLACE(G23;1;8;"Klaipėdos")=Klaipėdos universitetas.

10. REPT(text;number_times[pakartojimų skaičius]). Pakartojamas tekstas tiek kartų, kiek nurodyta.
Pvz.: =REPT("radau ";4)=radau radau radau radau. Įdedame tarpą ar kitą skyriklį, jei to reikia.
11. T(value). Gražina tekstą, jei vertė yra tekstas ir gražina tuščią tarpą, jei vertė yra skaičius. Netaikyti formulėms.

12. TRIM("text"). Išmeta iš teksto dvigubus, trigubus tarpelius. Palieka vieną tarpelį tarp žodžių.
13. ROMAN(number;form). Konvertuoja arabiškus skaičius į romėniškuosius. Form nusako rašymo stilių: 0 (pagal nutylėjimą) atitinka klasikinį užrašymą. form=1, 2, 3, 4 atitinka supaprastintus rašymo variantus (žr. pagalbos žinyną).
Pvz.: =ROMAN(5)=V; =ROMAN(555)=DLV;

Datos ir laiko funkcijos

Atliekant skaičiavimus su datomis, pirmiausia data paverčiama realiais skaičiais, atliekami reikiami veiksmai ir po to atsakymas vėl konvertuojamas į datos formatą. Trupmeninė skaičiaus dalis atitinka paros laiką.

Skaičiavimams gali būti vartojamos dvi datos atskaitos sistemos. Pvz., datai 1900 m. sausio 1 d.  (1900 m. sausio 1 d. =1 – viena sistema; 1904 m. sausio 2 d. =1 – kita sistema) suteiktas numeris lygus 1, o didžiausią galimą numerį 2 958 465 atitinka 9999 m. gruodžio 31 d.
Sistema pasirenkama : Tools>Options, Calculations. 
Skaičiavimai su datos funkcijomis atliekami, kai langeliuose duomenys turi datos formatą: Format>Cells, Number. Kategorijos laukelyje pažymėkite Date, o Type sąraše pasirinkite datos formatą. Jei datos formato nepriskyrėte, bet rašote datą esančiu programos sąraše datos formatu, programa atpažįsta datą. Jei parašytų duomenų programa neatpažįsta, jie saugomi kaip tekstas. Tuomet veiksmų atlikti negalėsite.
Metų rašymo būdai: kai rašomi du skaitmenys, 2000 m. problema taip išspręsta:

– 00÷29 keičiama į 2000÷2029 m. ir 

– 30÷99 keičiama į 1930÷1999 m.

Visais kitais atvejais (tarp 1900.01.01 ir 1929.12.31 ir nuo 2030.01.01) metams nusakyti geriau rašyti keturženklį skaičių.
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Pvz.: DATE(1998;1;1)=35796=1998.1.1.
Su šia funkcija datą galima įterpti į formulę ir naudoti skaičiavimams. Kad matytume į kokį realų skaičių verčiama data, reikia langeliui, kuriame parašyta data, suteikti skaičiaus formatą. Ir atvirkščiai, kai turite realų skaičių, jį išreikšite data, langeliui suteikę datos formatą.
Kitas pvz. Sudėkite 2001.1.1 ir 2010.1.1  =SUM("2001.1.1";2010.1.1")=2111.01.04.
2. DATEVALUE(date_text). Grąžinamas skaitmeninis datos formatas, jei data pateikiama teksto pavidalu.

Pvz.: DATEVALUE("2004.11.3")=38294.

3. EDATE(start_date;months). Grąžina datą skaitmeniniu formatu, besiskiriančiu nurodytu mėnesių skaičiumi. Ši funkciją įkeliama papildomai iš Analysis Tools Pack.

Pvz.: =EDATE(DATAVALUE("1998.03.31");-1)=1998 m. vasario 28 d.

3. TIME(hour;minute;second). Grąžina laiką kaip dešimtainį skaičių 0÷0,999999999.

Kitimo ribos: Hour=0÷23; minute=0÷25; second=0÷59. Angliškai: AM=prieš piet; PM= po pietų.

Pvz.: =TIME(16;48;10)=0,700115741=4:48:10PM=16:48:10. Skaičių matysite, kai langeliui suteiksite skaičiaus formatą.
4. MONTH(serial_number). Paverčia mėnesį į sveiką skaičių, kuris naudojamas skaičiavimuose.
Pvz.: =MONTH(35796)=1, nes 35796=1998.01.01.

5. NOW(). Paverčia esamą laiką ir datą skaitine išraiška. Funkcija neturi argumentų. Atsakymas kintamas. Naudojamas makrokomandose. Automatiškai neatnaujinama.
6. TODAY(). Paverčia esamą datą skaitine išraiška. Funkcija neturi argumentų. Atsakymas kintamas. Jei langelio formatas yra General, tai funkcijos gražinama vertė bus išreikšta datos pavidalu.
7. Weekday(serial_number;return_type). Argumentai: metai, galima rašyti tekstiniam pavidale; antrasis argumentas nusako savaitės dieną. Galimi trys variantai: 

1, jei savaitė prasideda sekmadieniu-1 ir baigiasi šeštadieniu - 7;

2, jei savaitė prasideda pirmadieniu - 1, ir baigiasi sekmadieniu - 7;

3, jei savaitė prasideda sekmadieniu - 0 ir baigiasi šeštadieniu - 6.

KLAIDOS
Rašomas pranešimas:

##### – kai reikšmės netelpa į langelį;


– formulės rezultatas yra data ar laikas su neigiamu ženklu.

#Value – kai naudojamas neteisingas argumento tipas (tekstas vietoje skaičiaus ar loginės TRUE, FALSE vertės)


– masyvo atveju formulei redaguoti spauskite F2


– masyvo atveju formulei suskaičiuoti spauskite CTRL+SHIFT+ENTER.


– įvedėte langelių sritį, kai reikalingas tik vienas langelis;


– įvedėte neegzistuojančios funkcijos pavadinimą.

#DIV/0! – kai formulėje yra nuoroda į tuščią langelį ar langelį, kuriame yra nulis, kaip daliklis (tuščias langelis prilyginamas nuliui).
#NAME – negali atpažinti vardo formulėje;


– neteisingai parašytas vardas;


– parašytas tekstas be kabučių;


– nurodant sritį, praleistas dvitaškis.
#N/A  
– formulei ar funkcijai nurodyta vertė neprieinama. Į tokius langelius geriau įrašyti "#N/A" - tuomet formulė nebus skaičiuojama;


– parašyta netinkama vertė;  

– masyve nelygus eilučių ir stulpelių skaičius ;

– praleistas argumentas;


– kreipiatės į neegzistuojančią funkciją.

#REF!
– neteisinga langelio nuoroda arba jis ištrintas.

#NUM!
 –  klaida su skaičiumi formulėje arba funkcijoje;


– naudojamas netinkamas argumentas formulėje, kai reikalingas skaičius.

#NULL! – įvestos langelių sritys kaip susikertančios o iš tikrųjų nesusikerta;


– nurodyta neteisinga langelių sritis.
HISTOGRAMOS (DIAGRAMOS, GRAFIKAI)
Skaičiavimų skaitinės vertės yra reikšmingos, tačiau sunkiai parodo santykį su kitomis vertėmis, neatskleidžia kitimo tendencijų. Su šia užduotimi puikiai susidoroja grafinė tų pačių verčių išraiška. Galima atskleisti tendencijas ir palyginti jas tarpusavyje.

Excelyje vartojami keli diagramų tipai, pagal savo struktūrą ir prasmę turintys skirtingus pavadinimus.

I. Vertikalioji histograma (Column, Bar) naudojama, kai turime diskrečius duomenis ir norime parodyti jų priklausomybę nuo kintančio dydžio ar kitimo laike.
Pavyzdys: 
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II. Horizontalioji (Bar) histograma tinka palyginti individualias vertes tarpusavyje. Čia x ašies vertes atidedame y ašyje, o y ašies vertes – x ašyje.

Pavyzdys:
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III. Erdvinė histograma (3-D Column, 3-Bar). Naudojama parodyti duomenų priklausomybę nuo skirtingų parametrų, pvz., prekyba ketvirčiais skirtinguose filialuose.

Pavyzdys:
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IV. Sudėtinių verčių histogramos (Stacked Column, Stacked Bar).Galima palyginti sudedamųjų dalių indėlį, pvz., kiekvieno filialo indėlis į bendrą sumą skirtingais ketvirčiais.

Pavyzdys:
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 V. Plotinės diagramos (Area) pabrėžia nepertraukiamo dydžio kitimą laike, o užpildytos sritys išryškina vienos dalies indėlį į kitą.
Pavyzdys:
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VI. Linijinė diagrama (Line) parodo duomenų kitimo tendenciją laike arba vieno dydžio priklausomybę nuo kito.

Pavyzdys:
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VII. Skritulinė diagrama (Pie) parodo procentinį reikšmių pasiskirstymą – santykį tam tikros vertės ir visumos. Galima atvaizduoti tik vieną duomenų seką.
Pavyzdys:
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VIII. Žiedinė histograma (Doughnut), parodo procentinį kelių duomenų sekų reikšmių pasiskirstymą.
Pavyzdys:
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IX. Spindulinė diagrama (Radar). Kiekviena x verčių seka turi savo y ašį, besitesiančią nuo centro. Linijos diagramoje jungia tos pačios sekos vertes. Tokio tipo diagramos lygina sumines duomenų sekos vertes (lyginami užimami plotai).
Pavyzdys:
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X. Paviršinė diagrama (Surface). Naudojama tada, kai norima parodyti parametro kitimą, priklausomai nuo kitų dviejų tarpusavyje nepriklausomųjų. Pvz. metalo įtempimai nuo temperatūros ir nuo laiko.
XI. Taškinė diagrama (Scater) vaizduoja diskrečių verčių išsibarstymą atžvilgiu kitos (kontrolinės) sekos.

XII. Burbulinė diagrama (Buble) yra panaši į taškinę, tik čia dar yra trečias dydis, kurio vertę simbolizuoja taško dydis.

Pavyzdys: 
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Diagramos kūrimas

Diagramą geriausiai kurti, vadovaujant Excelio vedliui – Chart Wizard. Pažymėkite duomenis ir spustelėkite standartinėje įrankių juostoje mygtuką [image: image26.bmp], arba Insert>Chart. 
Vedlys atvers dialogo langą, kuriame pasirinkite diagramos tipą. Jų aprašą matysite lango dešinėje. Nuspauskite mygtuką Next. 
Dabar Chart Sourse data lange galite patikslinti duomenis, jei kompiuteris neteisingai juos priskyrė atitinkamoms koordinačių ašims. Data range – tai diagramoje vaizduojamų duomenų sritis. Paprastai, jei duomenys buvo pažymėti, tai kompiuteris juos teisingai įvardija. Series puslapyje galite redaguoti duomenų sekas, jas išimti ar pridėti. Čia galima duomenų sekoms suteikti pavadinimus (Name laukelis), patikslinti x ašies vertes (Category x axis labels:). Padaryti pakeitimai iš karto atsispindi pavyzdyje. 

Nuspaudę Next, pateksite į trečią dialogo langą – Chart options. Pirmame puslapyje parašykite diagramos pavadinimą, nurodykite koordinacinių ašių pavadinimus, matavimo vienetus. Axes puslapyje, jei x ašyje norite atidėti laiko skalę, fiksuokite Time-scale. Gridlines puslapyje pasirenkate rodyti ar nerodyti koordinacinį tinkliuką. Legend puslapyje galite atsisakyti rodyti duomenų aprašą (jei turite tik vieną seką), pasirinkti aprašo vietą. Data label puslapyje galima pažymėti, kad būtų rodomi duomenų pavadinimai ar jų vertės. Data Table puslapyje šalia grafiko galite nurodyti ir duomenų lentelę. 
Dar kartą nuspaudę Next mygtuką , pateksite į Chart Location dialogo langą, kur galėsite nurodyti diagramą patalpinti atskirame darbolapyje (As new sheet) ar tame pačiame darbolapyje šalia duomenų (As object in). Šiame dialogo lange į išvardintus puslapius galite ir neužsukti. Vėliau, bet kada galėsite į išvardytas grafiko sritis užsukti, du kartus spragtelėję grafiko srityje reikiamoje vietoje.

Galiausiai spustelėkite mygtuką Finish. Programa pateiks sukurtą diagramą. Ją galite didinti/mažinti, nešioti.  Kai diagrama pažymėta, atsiranda Chart įrankių juosta, kurioje susiradę reikiamą komandą galėsite diagramoje pakoreguoti spalvas, koordinacines ašis ir t.t. Reikiamas komandas rasite ir meniu Chart, kuris pasirodo vietoje meniu Data (kai pažymite diagramą).
Kai pažymite diagramą, programa nuspalvina ir diagramos duomenis. Jei minėti duomenys atnaujinami, iš karto pasikeičia rezultatai ir diagramoje.
Diagramos papildymas duomenimis 

Yra keli būdai naujais duomenimis papildyti diagramą. 

1) kai diagrama pažymėta, Chart meniu susiraskite komandą Add data. Atvertame Add data dialogo lange, jo neuždarę, pažymite naujus duomenis, fiksuojate OK. Gausite naują seką diagramoje;

2) naujus duomenis pažymėkite, juos nukopijuokite į saugyklą. Pažymėkite diagramą ir įklijuokite (Paste) naujus duomenis;
3) pažymėkite diagramą; atidarykite meniu Chart, susiraskite komandą Source data. Šiame dialogo lange nuspauskite Add mygtuką, pažymėkite naujus duomenis, OK.
Duomenų išėmimas iš diagramos

Jei ištrinsite pačius duomenis, išnyks atitinkama duomenų seka ir diagramoje.

Diagramos įkėlimas į tekstinį dokumentą

Pažymėkite diagramą, ją nukopijuokite. Pereikite į Wordą, atidarykite reikiamą dokumentą. Diagramą galite įklijuoti dviem būdais:

– komanda Įklijuoti, įterpsite diagramą į reikiamą vietą. Ryšys su originalu Excelyje bus nutrauktas;

– atidarykite meniu Redagavimas ir susiraskite komandą Specialusis įklijavimas. Atvertame dialogo lange, jei pasirinksite Įklijuoti saitą, įklijuosite diagramą, kuri išlaikys ryšį su originalu Excelyje. Kitaip tariant, jei darysite diagramoje pakeitimus Excelyje, tai pastarieji irgi bus padaryti automatiškai ir wordiniame dokumente. 
Diagramos spausdinimas skaičiuoklėje
Jei diagramą pažymėsite ir po to spausdinsite, bus atspausdinta diagrama. Galėsite pasirinkti ar spausdinti tokią kokia yra ar išdidinti per visą puslapį.

Jei diagrama nėra pažymėta, tai spausdinamas visas puslapis: ir duomenys, ir diagrama.
ĮSIDĖMĖTINOS TAISYKLĖS
Funkcijų vartojimo taisyklės; darbas su diagramomis
1) Pagrindinės taisyklės vartojant funkcijas:
· prasideda lygybės ženklu;

· argumentais gali būti skaičiai (numbers), loginės vertės (true, false), tekstas. Pastarasis rašomas kabutėse. 

· skaičiavimuose true skaitine verte prilyginamas 1, o false – 0. 

· tarp argumentų rašomas skyrybos ženklas kabliataškis. Tarpai negalimi, išskyrus vienintelį atveją – sankirtos operatorių. Tuomet tarp sričių padaromas tarpas, pvz: =sum(A1:A3 A1B1). Atsakymas reikšmė abiejų sričių susikirtimo langelio vertė.

· sričių operatorius vartojamas tik su funkcijomis.

· greitam sumavimui naudokite mygtuką su graikiška raide sigma: pažymite duomenis ir vieną tuščią langelį (jame bus atsakymas) ir spaudžiate minėtą mygtuką.

· parašę lygybę, populiarias dažnai jūsų vartojamas funkcijas rasite formulės juostos pradžioje, nuspaudę trikampį.

· Shift+F3 – pats greičiausias būdas pradėti rašyti funkciją.

· parašytą funkciją suskaičiuosite nuspaudę Enter klavišą arba žalią varnelę formulės juostoje. 

· Escape klavišo paspaudimas – tai išėjimas iš formulės redagavimo režimo, nekeičiant formulės.

· kai rašote formulę, be reikalo nespragsėkite pele per atsitiktinius langelius, nes jie bus įtraukti į formulės argumentų sąrašą.

· sukurtą formulę galite kopijuoti į kitus langelius.

· formulės rezultatai bus perskaičiuojami nuspaudus F9 klavišą.

2) Diagramų valdymo taisyklės
· diagramoms kurti naudokite vedlį [image: image27.bmp]. Pažymėkite duomenis tokia tvarka: pirmiausia x ašies duomenis, toliau y ašies duomenis, spauskite vedlio mygtuką...

· gautą diagramą visuomet galite pakoreguoti, naudodami Chart įrankių juostą arba meniu Chart (šis meniu atsiras vietoje Data meniu, kai pažymėsite diagramą).

· vienos rūšies diagrama lengvai pakeisite į kitos rūšies diagramą, Chart įrankių juostoje su tam skirtu mygtuku.

· kai pažymėta diagrama, panaudotų duomenų langeliai įrėminami spalvotai.

· du kartus spragtelėję per diagramos sritį, galėsite keisti tos srities savybes.

· papildomą duomenų seką į jau gautą diagramą įdiegsite, jei nukopijuosite duomenis ir juos įklijuosite į diagramą: pažymite diagramą ir Paste.

· duomenų seką iš diagramos pašalinsite, kai ją pažymėsite su pele ir paspausite Delete klavišą.

· Jei tam tikros sekos duomenys labai skiriasi nuo kitų duomenų, tai minėtai duomenų sekai galite panaudoti papildomą y ašį. iš pradžių mažų duomenų seką įterpiame į diagramą įprastu būdu, po to pažymime tą seką diagramoje ir iškviečiame komandą Format>Select Data Series. Tuomet atitinkamuose dialogo languose matysite dvi y ašis.

· jei norite x ašyje turėti laiko ašį, t.y. nuoseklią skaičių seką, tai šiuo atveju x ašies duomenų nurodyti nereikia. x ašyje kompiuteris atidės nuoseklią skaičių seką, priklausomai kiek langelių užima y duomenys. Pvz., jei y duomenys yra stulpelyje ir užima10 langelių, tai x ašyje bus tolygiai išsidėstę skaičiai nuo 0 iki 10.[image: image28.png]
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Duomenų stulpelyje sutraukimo įrankis
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